CVE-2025-48985
CVE-2025-48985
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
CVSS 3.7 · Faible · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
ai sdk
- Versions du logiciel
- ≥ 5.0.51, ≤ 5.0.51: Concernée (semver)
- ≥ 6.0.0-beta.*, < 6.0.0-beta.*: Non concernée (semver)
- ≥ 5.1.0-beta.8, ≤ 5.1.0-beta.8: Concernée (semver)
- ≥ 5.1.0-beta.9, < 5.1.0-beta.9: Non concernée (semver)
- ≥ 5.0.52, < 5.0.52: Non concernée (semver)
Aucun correctif publié
ai npm
- Plages de versions concernées
- SEMVER: < 5.0.52
Mettez à jour vers 5.0.52
ai npm
- Plages de versions concernées
- SEMVER: ≥ 5.1.0-beta.0, < 5.1.0-beta.9
Mettez à jour vers 5.1.0-beta.9