CVE-2025-48985
CVE-2025-48985
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
CVSS 3.7 · Low · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
ai sdk
- Versions
- ≥ 5.0.51, ≤ 5.0.51: Affected (semver)
- ≥ 6.0.0-beta.*, < 6.0.0-beta.*: Not affected (semver)
- ≥ 5.1.0-beta.8, ≤ 5.1.0-beta.8: Affected (semver)
- ≥ 5.1.0-beta.9, < 5.1.0-beta.9: Not affected (semver)
- ≥ 5.0.52, < 5.0.52: Not affected (semver)
No fix published
ai npm
- Affected ranges
- SEMVER: < 5.0.52
Update to 5.0.52
ai npm
- Affected ranges
- SEMVER: ≥ 5.1.0-beta.0, < 5.1.0-beta.9
Update to 5.1.0-beta.9