CVE-2025-48985
CVE-2025-48985
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
CVSS 3.7 · Niedrig · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
ai sdk
- Softwareversionen
- ≥ 5.0.51, ≤ 5.0.51: Betroffen (semver)
- ≥ 6.0.0-beta.*, < 6.0.0-beta.*: Nicht betroffen (semver)
- ≥ 5.1.0-beta.8, ≤ 5.1.0-beta.8: Betroffen (semver)
- ≥ 5.1.0-beta.9, < 5.1.0-beta.9: Nicht betroffen (semver)
- ≥ 5.0.52, < 5.0.52: Nicht betroffen (semver)
Keine Korrektur veröffentlicht
ai npm
- Betroffene Versionsbereiche
- SEMVER: < 5.0.52
Auf 5.0.52 aktualisieren
ai npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.1.0-beta.0, < 5.1.0-beta.9
Auf 5.1.0-beta.9 aktualisieren