p PatchFirst

CVE-2025-58177

CVE-2025-58177 · n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

CVSS 5.4 · Moyenne · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • n8n

    Versions du logiciel
    • >= 1.24.0, < 1.107.0: Concernée

    Aucun correctif publié

  • n8n npm

    Plages de versions concernées
    • SEMVER: ≥ 1.24.0, < 1.107.0

    Mettez à jour vers 1.107.0

Sources originales

Vérifiez votre serveur →