p PatchFirst

CVE-2025-58177

CVE-2025-58177 · n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

CVSS 5.4 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • >= 1.24.0, < 1.107.0: Affected

    No fix published

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 1.24.0, < 1.107.0

    Update to 1.107.0

Original sources

Check your server →