p PatchFirst

CVE-2025-58177

CVE-2025-58177 · n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

CVSS 5.4 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • n8n

    Softwareversionen
    • >= 1.24.0, < 1.107.0: Betroffen

    Keine Korrektur veröffentlicht

  • n8n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.24.0, < 1.107.0

    Auf 1.107.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →