CVE-2025-59037
CVE-2025-59037 · DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.
CVSS 8.6 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
duckdb-node
- Versions du logiciel
- = 1.3.3: Concernée
- = 1.29.2: Concernée
Aucun correctif publié
duckdb npm
- Versions du logiciel
- 1.3.3
- Plages de versions concernées
- SEMVER: ≥ 1.3.3, < 1.3.4
Mettez à jour vers 1.3.4
@duckdb/node-api npm
- Versions du logiciel
- 1.3.3
- Plages de versions concernées
- SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27
Mettez à jour vers 1.3.4-alpha.27
@duckdb/node-bindings npm
- Versions du logiciel
- 1.3.3
- Plages de versions concernées
- SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27
Mettez à jour vers 1.3.4-alpha.27
@duckdb/duckdb-wasm npm
- Versions du logiciel
- 1.29.2
- Plages de versions concernées
- SEMVER: ≥ 1.29.2, < 1.30.0
Mettez à jour vers 1.30.0