p PatchFirst

CVE-2025-59037

CVE-2025-59037 · DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware

This page contains facts from public vulnerability sources. Check the original advisory before updating.

DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.

CVSS 8.6 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • duckdb-node

    Versions
    • = 1.3.3: Affected
    • = 1.29.2: Affected

    No fix published

  • duckdb npm

    Versions
    • 1.3.3
    Affected ranges
    • SEMVER: ≥ 1.3.3, < 1.3.4

    Update to 1.3.4

  • @duckdb/node-api npm

    Versions
    • 1.3.3
    Affected ranges
    • SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27

    Update to 1.3.4-alpha.27

  • @duckdb/node-bindings npm

    Versions
    • 1.3.3
    Affected ranges
    • SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27

    Update to 1.3.4-alpha.27

  • @duckdb/duckdb-wasm npm

    Versions
    • 1.29.2
    Affected ranges
    • SEMVER: ≥ 1.29.2, < 1.30.0

    Update to 1.30.0

Original sources

Check your server →