CVE-2025-59037
CVE-2025-59037 · DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
DuckDB is an analytical in-process SQL database management system. On 08 September 2025, the DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of DuckDB's packages that included malicious code to interfere with cryptocoin transactions* According to the npm statistics, nobody has downloaded these packages before they were deprecated. The packages and versions `@duckdb/[email protected]`, `@duckdb/[email protected]`, `[email protected]`, and `@duckdb/[email protected]` were affected. DuckDB immediately deprecated the specific versions, engaged npm support to delete the affected verions, and re-released the node packages with higher version numbers (1.3.4/1.30.0). Users may upgrade to versions 1.3.4, 1.30.0, or a higher version to protect themselves. As a workaround, they may also downgrade to 1.3.2 or 1.29.1.
CVSS 8.6 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
duckdb-node
- Softwareversionen
- = 1.3.3: Betroffen
- = 1.29.2: Betroffen
Keine Korrektur veröffentlicht
duckdb npm
- Softwareversionen
- 1.3.3
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.3.3, < 1.3.4
Auf 1.3.4 aktualisieren
@duckdb/node-api npm
- Softwareversionen
- 1.3.3
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27
Auf 1.3.4-alpha.27 aktualisieren
@duckdb/node-bindings npm
- Softwareversionen
- 1.3.3
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.3.3, < 1.3.4-alpha.27
Auf 1.3.4-alpha.27 aktualisieren
@duckdb/duckdb-wasm npm
- Softwareversionen
- 1.29.2
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.29.2, < 1.30.0
Auf 1.30.0 aktualisieren