p PatchFirst

CVE-2025-59057

CVE-2025-59057 · React Router has XSS Vulnerability

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.

CVSS 7.6 · Élevée · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • react-router

    Versions du logiciel
    • @remix-run/react >= 1.15.0, < 2.17.1: Concernée
    • react-router >= 7.0.0, < 7.9.0: Concernée

    Aucun correctif publié

  • react-router npm

    Plages de versions concernées
    • SEMVER: ≥ 7.0.0, < 7.9.0

    Mettez à jour vers 7.9.0

  • @remix-run/react npm

    Plages de versions concernées
    • SEMVER: ≥ 1.15.0, < 2.17.1

    Mettez à jour vers 2.17.1

Sources originales

Vérifiez votre serveur →