p PatchFirst

CVE-2025-59057

CVE-2025-59057 · React Router has XSS Vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.

CVSS 7.6 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • react-router

    Softwareversionen
    • @remix-run/react >= 1.15.0, < 2.17.1: Betroffen
    • react-router >= 7.0.0, < 7.9.0: Betroffen

    Keine Korrektur veröffentlicht

  • react-router npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.9.0

    Auf 7.9.0 aktualisieren

  • @remix-run/react npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.15.0, < 2.17.1

    Auf 2.17.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →