p PatchFirst

CVE-2025-59057

CVE-2025-59057 · React Router has XSS Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.

CVSS 7.6 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • react-router

    Versions
    • @remix-run/react >= 1.15.0, < 2.17.1: Affected
    • react-router >= 7.0.0, < 7.9.0: Affected

    No fix published

  • react-router npm

    Affected ranges
    • SEMVER: ≥ 7.0.0, < 7.9.0

    Update to 7.9.0

  • @remix-run/react npm

    Affected ranges
    • SEMVER: ≥ 1.15.0, < 2.17.1

    Update to 2.17.1

Original sources

Check your server →