p PatchFirst

CVE-2025-67647

CVE-2025-67647 · SvelteKit Denial of service and possible SSRF when using prerendering

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

CVSS 8.4 · Élevée · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • kit

    Versions du logiciel
    • >= 2.19.0, < 2.49.5: Concernée

    Aucun correctif publié

  • @sveltejs/kit npm

    Plages de versions concernées
    • SEMVER: ≥ 2.19.0, < 2.49.5

    Mettez à jour vers 2.49.5

  • @sveltejs/adapter-node npm

    Plages de versions concernées
    • SEMVER: ≥ 5.4.1, < 5.5.1

    Mettez à jour vers 5.5.1

Sources originales

Vérifiez votre serveur →