p PatchFirst

CVE-2025-67647

CVE-2025-67647 · SvelteKit Denial of service and possible SSRF when using prerendering

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

CVSS 8.4 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • kit

    Versions
    • >= 2.19.0, < 2.49.5: Affected

    No fix published

  • @sveltejs/kit npm

    Affected ranges
    • SEMVER: ≥ 2.19.0, < 2.49.5

    Update to 2.49.5

  • @sveltejs/adapter-node npm

    Affected ranges
    • SEMVER: ≥ 5.4.1, < 5.5.1

    Update to 5.5.1

Original sources

Check your server →