p PatchFirst

CVE-2025-67647

CVE-2025-67647 · SvelteKit Denial of service and possible SSRF when using prerendering

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

CVSS 8.4 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • kit

    Softwareversionen
    • >= 2.19.0, < 2.49.5: Betroffen

    Keine Korrektur veröffentlicht

  • @sveltejs/kit npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.19.0, < 2.49.5

    Auf 2.49.5 aktualisieren

  • @sveltejs/adapter-node npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.4.1, < 5.5.1

    Auf 5.5.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →