CVE-2026-12957
CVE-2026-12957 · Arbitrary Code Execution in Language Servers for AWS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
CVSS 8.5 · Élevée · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
language servers for aws
- Versions du logiciel
- ≥ 0, < 1.65.0: Concernée (semver)
Mettez à jour vers 1.65.0
@aws/lsp-codewhisperer npm
- Plages de versions concernées
- SEMVER: < 0.0.113
Mettez à jour vers 0.0.113