CVE-2026-12957
CVE-2026-12957 · Arbitrary Code Execution in Language Servers for AWS
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
CVSS 8.5 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
language servers for aws
- Softwareversionen
- ≥ 0, < 1.65.0: Betroffen (semver)
Auf 1.65.0 aktualisieren
@aws/lsp-codewhisperer npm
- Betroffene Versionsbereiche
- SEMVER: < 0.0.113
Auf 0.0.113 aktualisieren