p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @aws/lsp-codewhisperer

Vulnérabilité publiée pour @aws/lsp-codewhisperer au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-12958

    Élevée · CVSS 8.5EPSS 0,19%Correctif disponible

    Arbitrary file write in Language Servers for AWS

    Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.

    • Mettez à jour vers 0.0.117
    Publication Mise à jour
  2. CVE-2026-12957

    Élevée · CVSS 8.5EPSS 0,23%Correctif disponible

    Arbitrary Code Execution in Language Servers for AWS

    Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

    • Mettez à jour vers 0.0.113
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →