CVE-2026-34743
CVE-2026-34743 · XZ Utils: Buffer overflow in lzma_index_append()
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.
CVSS 1.7 · Faible · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
xz
- Versions du logiciel
- < 5.8.3: Concernée
Aucun correctif publié
xz-utils Debian:12
- Versions du logiciel
- 5.4.1-0.2
- 5.4.1-1
- Plages de versions concernées
- ECOSYSTEM: < 5.4.1-1+deb12u1
Mettez à jour vers 5.4.1-1+deb12u1
xz-utils Debian:13
- Versions du logiciel
- 5.8.1-1
- Plages de versions concernées
- ECOSYSTEM: < 5.8.1-1+deb13u1
Mettez à jour vers 5.8.1-1+deb13u1
xz-utils Debian:14
- Versions du logiciel
- 5.8.1-1
- 5.8.1-1.1
- 5.8.1-2
- 5.8.2-1
- 5.8.2-2
- Plages de versions concernées
- ECOSYSTEM: < 5.8.3-1
Mettez à jour vers 5.8.3-1
xz-utils Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 5.1.1alpha+20120614-2ubuntu1
- 5.1.1alpha+20120614-2ubuntu2
- 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm2
Mettez à jour vers 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm2
xz-utils Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 5.1.1alpha+20120614-2ubuntu2
- 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm2
Mettez à jour vers 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm2
xz-utils Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 5.2.2-1.3
- 5.2.2-1.3ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 5.2.2-1.3ubuntu0.1+esm1
Mettez à jour vers 5.2.2-1.3ubuntu0.1+esm1
xz-utils Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 5.2.4-1
- 5.2.4-1ubuntu1
- 5.2.4-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 5.2.4-1ubuntu1.1+esm1
Mettez à jour vers 5.2.4-1ubuntu1.1+esm1
xz-utils Ubuntu:22.04:LTS
- Versions du logiciel
- 5.2.5-2
- 5.2.5-2build1
- 5.2.5-2build2
- 5.2.5-2ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 5.2.5-2ubuntu1.1
Mettez à jour vers 5.2.5-2ubuntu1.1
xz-utils Ubuntu:24.04:LTS
- Versions du logiciel
- 5.4.1-0.2
- 5.4.4-0.1
- 5.4.5-0.1
- 5.4.5-0.3
- 5.6.0-0.2
- 5.6.1+really5.4.5-1
- 5.6.1+really5.4.5-1build0.1
- 5.6.1+really5.4.5-1ubuntu0.2
- Plages de versions concernées
- ECOSYSTEM: < 5.6.1+really5.4.5-1ubuntu0.3
Mettez à jour vers 5.6.1+really5.4.5-1ubuntu0.3
xz-utils Ubuntu:25.10
- Versions du logiciel
- 5.6.4-1ubuntu1
- 5.8.1-1
- 5.8.1-1build1
- 5.8.1-1build2
- Plages de versions concernées
- ECOSYSTEM: < 5.8.1-1ubuntu0.1
Mettez à jour vers 5.8.1-1ubuntu0.1
Sources originales
- https://github.com/tukaani-project/xz/security/advisories/GHSA-x872-m794-cxhv
- https://github.com/tukaani-project/xz/commit/c8c22869e780ff57c96b46939c3d79ff99395f87
- https://github.com/tukaani-project/xz/releases/tag/v5.8.3
- http://www.openwall.com/lists/oss-security/2026/03/31/13
- https://lists.debian.org/debian-lts-announce/2026/07/msg00034.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-34743