p PatchFirst

CVE-2026-34743

CVE-2026-34743 · XZ Utils: Buffer overflow in lzma_index_append()

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

CVSS 1.7 · Niedrig · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • xz

    Softwareversionen
    • < 5.8.3: Betroffen

    Keine Korrektur veröffentlicht

  • xz-utils Debian:12

    Softwareversionen
    • 5.4.1-0.2
    • 5.4.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.1-1+deb12u1

    Auf 5.4.1-1+deb12u1 aktualisieren

  • xz-utils Debian:13

    Softwareversionen
    • 5.8.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.8.1-1+deb13u1

    Auf 5.8.1-1+deb13u1 aktualisieren

  • xz-utils Debian:14

    Softwareversionen
    • 5.8.1-1
    • 5.8.1-1.1
    • 5.8.1-2
    • 5.8.2-1
    • 5.8.2-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.8.3-1

    Auf 5.8.3-1 aktualisieren

  • xz-utils Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 5.1.1alpha+20120614-2ubuntu1
    • 5.1.1alpha+20120614-2ubuntu2
    • 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm2

    Auf 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm2 aktualisieren

  • xz-utils Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 5.1.1alpha+20120614-2ubuntu2
    • 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm2

    Auf 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm2 aktualisieren

  • xz-utils Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 5.2.2-1.3
    • 5.2.2-1.3ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.2-1.3ubuntu0.1+esm1

    Auf 5.2.2-1.3ubuntu0.1+esm1 aktualisieren

  • xz-utils Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 5.2.4-1
    • 5.2.4-1ubuntu1
    • 5.2.4-1ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.4-1ubuntu1.1+esm1

    Auf 5.2.4-1ubuntu1.1+esm1 aktualisieren

  • xz-utils Ubuntu:22.04:LTS

    Softwareversionen
    • 5.2.5-2
    • 5.2.5-2build1
    • 5.2.5-2build2
    • 5.2.5-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.5-2ubuntu1.1

    Auf 5.2.5-2ubuntu1.1 aktualisieren

  • xz-utils Ubuntu:24.04:LTS

    Softwareversionen
    • 5.4.1-0.2
    • 5.4.4-0.1
    • 5.4.5-0.1
    • 5.4.5-0.3
    • 5.6.0-0.2
    • 5.6.1+really5.4.5-1
    • 5.6.1+really5.4.5-1build0.1
    • 5.6.1+really5.4.5-1ubuntu0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.6.1+really5.4.5-1ubuntu0.3

    Auf 5.6.1+really5.4.5-1ubuntu0.3 aktualisieren

  • xz-utils Ubuntu:25.10

    Softwareversionen
    • 5.6.4-1ubuntu1
    • 5.8.1-1
    • 5.8.1-1build1
    • 5.8.1-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.8.1-1ubuntu0.1

    Auf 5.8.1-1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →