p PatchFirst

CVE-2026-48068

CVE-2026-48068 · @grpc/grps-js: A malformed request can cause a server crash

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 7.5 · Élevée · EPSS 0,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • grpc-node

    Versions du logiciel
    • < 1.9.16: Concernée
    • >= 1.11.0, < 1.11.4: Concernée
    • >= 1.12.0, < 1.12.7: Concernée
    • >= 1.13.0, < 1.13.5: Concernée
    • >= 1.14.0, < 1.14.4: Concernée
    • >= 1.10.0, < 1.10.12: Concernée

    Aucun correctif publié

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: < 1.9.16

    Mettez à jour vers 1.9.16

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: ≥ 1.10.0, < 1.10.12

    Mettez à jour vers 1.10.12

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: ≥ 1.11.0, < 1.11.4

    Mettez à jour vers 1.11.4

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: ≥ 1.12.0, < 1.12.7

    Mettez à jour vers 1.12.7

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: ≥ 1.13.0, < 1.13.5

    Mettez à jour vers 1.13.5

  • @grpc/grpc-js npm

    Plages de versions concernées
    • SEMVER: ≥ 1.14.0, < 1.14.4

    Mettez à jour vers 1.14.4

Sources originales

Vérifiez votre serveur →