p PatchFirst

CVE-2026-48068

CVE-2026-48068 · @grpc/grps-js: A malformed request can cause a server crash

This page contains facts from public vulnerability sources. Check the original advisory before updating.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 7.5 · High · EPSS 0.9% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • grpc-node

    Versions
    • < 1.9.16: Affected
    • >= 1.11.0, < 1.11.4: Affected
    • >= 1.12.0, < 1.12.7: Affected
    • >= 1.13.0, < 1.13.5: Affected
    • >= 1.14.0, < 1.14.4: Affected
    • >= 1.10.0, < 1.10.12: Affected

    No fix published

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: < 1.9.16

    Update to 1.9.16

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: ≥ 1.10.0, < 1.10.12

    Update to 1.10.12

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: ≥ 1.11.0, < 1.11.4

    Update to 1.11.4

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: ≥ 1.12.0, < 1.12.7

    Update to 1.12.7

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: ≥ 1.13.0, < 1.13.5

    Update to 1.13.5

  • @grpc/grpc-js npm

    Affected ranges
    • SEMVER: ≥ 1.14.0, < 1.14.4

    Update to 1.14.4

Original sources

Check your server →