p PatchFirst

CVE-2026-55514

CVE-2026-55514 · vLLM denial of service via prompt embeds on M-RoPE models

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

CVSS 7.1 · Élevée · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • vllm

    Versions du logiciel
    • >= 0.12.0, < 0.24.0: Concernée

    Aucun correctif publié

  • vllm PyPI

    Versions du logiciel
    • 0.12.0
    • 0.13.0
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.17.1
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.19.1
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 0.12.0, < 0.24.0

    Mettez à jour vers 0.24.0

Sources originales

Vérifiez votre serveur →