p PatchFirst

CVE-2026-55514

CVE-2026-55514 · vLLM denial of service via prompt embeds on M-RoPE models

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

CVSS 7.1 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • >= 0.12.0, < 0.24.0: Affected

    No fix published

  • vllm PyPI

    Versions
    • 0.12.0
    • 0.13.0
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.17.1
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.19.1
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.12.0, < 0.24.0

    Update to 0.24.0

Original sources

Check your server →