CVE-2026-55514
CVE-2026-55514 · vLLM denial of service via prompt embeds on M-RoPE models
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
CVSS 7.1 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
vllm
- Softwareversionen
- >= 0.12.0, < 0.24.0: Betroffen
Keine Korrektur veröffentlicht
vllm PyPI
- Softwareversionen
- 0.12.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 0.12.0, < 0.24.0
Auf 0.24.0 aktualisieren
Originalquellen
- https://github.com/vllm-project/vllm/security/advisories/GHSA-33cg-gxv8-3p8g
- https://github.com/vllm-project/vllm/pull/45252
- https://github.com/vllm-project/vllm/commit/470229c37efaf69c86e8bc97482b0b1ff7551c65
- https://github.com/vllm-project/vllm/releases/tag/v0.24.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-55514