p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de node-jquery

Vulnérabilité publiée pour node-jquery au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2020-11023

    Moyenne · CVSS 6.9EPSS 84,89%Dans le catalogue KEVCode d’exploitation publicCorrectif disponible

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Mettez à jour vers 3.5.0+dfsg-2
    Publication Mise à jour
  2. CVE-2020-11022

    Moyenne · CVSS 6.9EPSS 99,22%Code d’exploitation publicCorrectif disponible

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Mettez à jour vers 3.5.0+dfsg-2
    Publication Mise à jour
  3. CVE-2019-11358

    Moyenne · CVSS 6.1EPSS 86,82%Code d’exploitation publicCorrectif disponible

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Mettez à jour vers 2.2.4+dfsg-4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →