p PatchFirst

PatchFirst · Latest vulnerabilities

node-jquery vulnerabilities

Vulnerabilities published for node-jquery in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2020-11023

    Medium · CVSS 6.9EPSS 84.89%In KEVPublic exploitFix available

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 3.5.0+dfsg-2
    Published Updated
  2. CVE-2020-11022

    Medium · CVSS 6.9EPSS 99.22%Public exploitFix available

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 3.5.0+dfsg-2
    Published Updated
  3. CVE-2019-11358

    Medium · CVSS 6.1EPSS 86.82%Public exploitFix available

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Update to 2.2.4+dfsg-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →