p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in node-jquery

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für node-jquery: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2020-11023

    Mittel · CVSS 6.9EPSS 84,89%Im KEV-KatalogÖffentlicher ExploitKorrektur verfügbar

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Auf 3.5.0+dfsg-2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-11022

    Mittel · CVSS 6.9EPSS 99,22%Öffentlicher ExploitKorrektur verfügbar

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Auf 3.5.0+dfsg-2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-11358

    Mittel · CVSS 6.1EPSS 86,82%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Auf 2.2.4+dfsg-4 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →