GHSA-q2c6-c6pm-g3gh
GHSA-q2c6-c6pm-g3gh · Arbitrary Code Execution in handlebars
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
handlebars npm
- Plages de versions concernées
- SEMVER: < 3.0.8
Mettez à jour vers 3.0.8
handlebars npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.5.3
Mettez à jour vers 4.5.3