GHSA-q2c6-c6pm-g3gh
GHSA-q2c6-c6pm-g3gh · Arbitrary Code Execution in handlebars
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.
Fix available
- Published
- Updated
Stack: node
Affected products and versions
handlebars npm
- Affected ranges
- SEMVER: < 3.0.8
Update to 3.0.8
handlebars npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.5.3
Update to 4.5.3