p PatchFirst

GHSA-q2c6-c6pm-g3gh

GHSA-q2c6-c6pm-g3gh · Arbitrary Code Execution in handlebars

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • handlebars npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.0.8

    Auf 3.0.8 aktualisieren

  • handlebars npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.5.3

    Auf 4.5.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →