p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @backstage/plugin-proxy-backend

Vulnérabilités publiées pour @backstage/plugin-proxy-backend au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-106491

    Moyenne · CVSS 6.4EPSS 0,27%Correctif disponible

    Backstage: Improper input validation in proxy-backend

    Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.

    • Mettez à jour vers 0.6.17
    Publication Mise à jour
  2. CVE-2026-106456

    Moyenne · CVSS 4.8EPSS 0,24%Correctif disponible

    Backstage: Inconsistent credential enforcement for overlapping proxy routes

    Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in versi

    • Mettez à jour vers 0.6.18
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →