CVE-2026-106456
CVE-2026-106456 · Backstage: Inconsistent credential enforcement for overlapping proxy routes
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVSS 4.8 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
backstage
- Versions du logiciel
- >= 1.28.0, < 1.55.0: Concernée
Aucun correctif publié
plugin-proxy-backend
- Versions du logiciel
- >= 0.5.0, < 0.6.18: Concernée
Aucun correctif publié
@backstage/plugin-proxy-backend npm
- Plages de versions concernées
- SEMVER: ≥ 0.5.0, < 0.6.18
Mettez à jour vers 0.6.18