p PatchFirst

PatchFirst · Latest vulnerabilities

@backstage/plugin-proxy-backend vulnerabilities

Vulnerabilities published for @backstage/plugin-proxy-backend in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-106491

    Medium · CVSS 6.4EPSS 0.27%Fix available

    Backstage: Improper input validation in proxy-backend

    Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.

    • Update to 0.6.17
    Published Updated
  2. CVE-2026-106456

    Medium · CVSS 4.8EPSS 0.24%Fix available

    Backstage: Inconsistent credential enforcement for overlapping proxy routes

    Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in versi

    • Update to 0.6.18
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →