p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ckeditor5

Vulnérabilités publiées pour ckeditor5 au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-116688

    Élevée · CVSS 8.1Correctif disponible

    CKEditor: Cross-site scripting (XSS) in the engine package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 45.0.0 until 47.7.4 and 48.5.1, the engine uses a vulnerable es-toolkit version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values. Crafted editor content can thereby cause unauthorized JavaScript execution in the browser. This issue is fixed in versions 47.7.4 and 48.5.1.

    • Mettez à jour vers 47.7.4
    • Mettez à jour vers 48.5.1
    Publication Mise à jour
  2. CVE-2026-116687

    Faible · CVSS 3.1Correctif disponible

    CKEditor: Cross-site scripting (XSS) in the engine package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.

    • Mettez à jour vers 47.7.4
    • Mettez à jour vers 48.5.1
    Publication Mise à jour
  3. CVE-2026-28343

    Moyenne · CVSS 6.4EPSS 0,28%Correctif disponible

    CKEditor: Cross-site scripting (XSS) in the HTML Support package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.

    • Mettez à jour vers 47.6.0
    Publication Mise à jour
  4. CVE-2025-58064

    Faible · CVSS 2.3EPSS 0,42%Correctif disponible

    CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducin

    • Mettez à jour vers 45.2.2
    • Mettez à jour vers 46.0.3
    Publication Mise à jour
  5. CVE-2024-45613

    Moyenne · CVSS 5.1EPSS 0,52%Correctif disponible

    CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package

    CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also en

    • Mettez à jour vers 43.1.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →