CVE-2025-58064
CVE-2025-58064 · CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
CVSS 2.3 · Faible · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
ckeditor5
- Versions du logiciel
- >= 46.0.0, < 46.0.3: Concernée
- >= 44.2.0, < 45.2.2: Concernée
Aucun correctif publié
ckeditor5 npm
- Plages de versions concernées
- SEMVER: ≥ 46.0.0, < 46.0.3
Mettez à jour vers 46.0.3
@ckeditor/ckeditor5-clipboard npm
- Plages de versions concernées
- SEMVER: ≥ 44.2.0, < 45.2.2
Mettez à jour vers 45.2.2
ckeditor5 npm
- Plages de versions concernées
- SEMVER: ≥ 44.2.0, < 45.2.2
Mettez à jour vers 45.2.2
@ckeditor/ckeditor5-clipboard npm
- Plages de versions concernées
- SEMVER: ≥ 46.0.0, < 46.0.3
Mettez à jour vers 46.0.3