p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de node-saml

Vulnérabilité publiée pour node-saml au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2025-54369

    Critique · CVSS 9.3EPSS 0,55%Aucun correctif publié

    Node-SAML SAML Authentication Bypass

    Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.

    Publication Mise à jour
  2. CVE-2022-39300

    Élevée · CVSS 7.7EPSS 0,78%Correctif disponible

    Signature bypass via multiple root elements in node-SAML

    node SAML is a SAML 2.0 library based on the SAML implementation of passport-saml. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to node-saml version 4.0.0-beta5 or newer. Disabling SAML authentication may be done as a workaround.

    • Mettez à jour vers 4.0.0-beta.5
    Publication Mise à jour
  3. CVE-2022-39299

    Élevée · CVSS 7.4EPSS 4,49%Correctif disponible

    Signature bypass via multiple root elements in Passport-SAML

    Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disa

    • Mettez à jour vers 4.0.0-beta.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →