p PatchFirst

CVE-2022-39299

CVE-2022-39299 · Signature bypass via multiple root elements in Passport-SAML

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

CVSS 7.4 · Élevée · EPSS 4,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • passport-saml

    Versions du logiciel
    • < 3.2.2: Concernée

    Aucun correctif publié

  • passport-saml npm

    Plages de versions concernées
    • SEMVER: < 3.2.2

    Mettez à jour vers 3.2.2

  • node-saml npm

    Plages de versions concernées
    • SEMVER: < 4.0.0-beta.5

    Mettez à jour vers 4.0.0-beta.5

  • @node-saml/node-saml npm

    Plages de versions concernées
    • SEMVER: < 4.0.0-beta.5

    Mettez à jour vers 4.0.0-beta.5

  • @node-saml/passport-saml npm

    Plages de versions concernées
    • SEMVER: < 4.0.0-beta.3

    Mettez à jour vers 4.0.0-beta.3

Sources originales

Vérifiez votre serveur →