p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in node-saml

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für node-saml: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2025-54369

    Kritisch · CVSS 9.3EPSS 0,55%Keine Korrektur veröffentlicht

    Node-SAML SAML Authentication Bypass

    Node-SAML is a SAML library not dependent on any frameworks that runs in Node. In versions 5.0.1 and below, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. This issue is fixed in version 5.1.0.

    Veröffentlicht Aktualisiert
  2. CVE-2022-39300

    Hoch · CVSS 7.7EPSS 0,78%Korrektur verfügbar

    Signature bypass via multiple root elements in node-SAML

    node SAML is a SAML 2.0 library based on the SAML implementation of passport-saml. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to node-saml version 4.0.0-beta5 or newer. Disabling SAML authentication may be done as a workaround.

    • Auf 4.0.0-beta.5 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-39299

    Hoch · CVSS 7.4EPSS 4,49%Korrektur verfügbar

    Signature bypass via multiple root elements in Passport-SAML

    Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disa

    • Auf 4.0.0-beta.5 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →