p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de prestashop/prestashop · Page n° 2

Vulnérabilité publiée pour prestashop/prestashop au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 31

  1. CVE-2023-30838

    Élevée · CVSS 8.6EPSS 1,04%Correctif disponible

    PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML

    • Mettez à jour vers 1.7.8.9
    • Mettez à jour vers 8.0.4
    Publication Mise à jour
  2. CVE-2023-30545

    Élevée · CVSS 7.7EPSS 0,86%Correctif disponible

    PrestaShop arbitrary file read vulnerability

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, it is possible for a user with access to the SQL Manager (Advanced Options -> Database) to arbitrarily read any file on the operating system when using SQL function `LOAD_FILE` in a `SELECT` request. This gives the user access to critical information. A patch is available in PrestaShop 8.0.4 and PS 1.7.8.9

    • Mettez à jour vers 1.7.8.9
    • Mettez à jour vers 8.0.4
    Publication Mise à jour
  3. CVE-2023-25170

    Moyenne · CVSS 5EPSS 0,22%Correctif disponible

    PrestaShop has possible CSRF token fixation

    PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.

    • Mettez à jour vers 8.0.1
    Publication Mise à jour
  4. CVE-2022-46158

    Moyenne · CVSS 5.3EPSS 0,5%Correctif disponible

    Potential Information exposure in the upload directory in PrestaShop

    PrestaShop is an open-source e-commerce solution. Versions prior to 1.7.8.8 did not properly restrict host filesystem access for users. Users may have been able to view the contents of the upload directory without appropriate permissions. This issue has been addressed and users are advised to upgrade to version 1.7.8.8. There are no known workarounds for this issue.

    • Mettez à jour vers 1.7.8.8
    Publication Mise à jour
  5. CVE-2022-31181

    Critique · CVSS 9.8EPSS 6,72%Code d’exploitation publicCorrectif disponible

    Remote code execution in prestashop

    PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.

    • Mettez à jour vers 1.7.8.7
    Publication Mise à jour
  6. CVE-2022-21686

    Critique · CVSS 9EPSS 1,79%Correctif disponible

    Server Side Twig Template Injection in PrestaShop

    PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.

    • Mettez à jour vers 1.7.8.3
    Publication Mise à jour
  7. CVE-2021-43789

    Élevée · CVSS 7.5EPSS 4,7%Correctif disponible

    Blind SQLi using Search filters in PrestaShop

    PrestaShop is an Open Source e-commerce web application. Versions of PrestaShop prior to 1.7.8.2 are vulnerable to blind SQL injection using search filters with `orderBy` and `sortOrder` parameters. The problem is fixed in version 1.7.8.2.

    • Mettez à jour vers 1.7.8.2
    Publication Mise à jour
  8. CVE-2019-11876

    Moyenne · CVSS 6.1EPSS 0,89%Correctif disponible

    CVE-2019-11876

    In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.

    • Mettez à jour vers 1.7.6.0
    Publication Mise à jour
  9. CVE-2018-20717

    Élevée · CVSS 8.8EPSS 2,69%Correctif disponible

    CVE-2018-20717

    In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

    • Mettez à jour vers 1.7.2.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →