p PatchFirst

PatchFirst · Vulnérabilités récentes

shopware/shopware 5.6.10 : vulnérabilités connues

Vulnérabilités connues concernant shopware/shopware 5.6.10 : 11. Comparez les versions corrigées ci-dessous avec celle que vous utilisez.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 11

  1. CVE-2023-34099

    Moyenne · CVSS 5.3EPSS 0,65%Correctif disponible

    Improper mail validation in Shopware

    Shopware is an open source e-commerce software. The mail validation in the registration process had some flaws, so it was possible to construct different mail addresses, that in the end result in the same address, which is shared by multiple accounts. This issue has been addressed in version 5.7.18 and users are advised to update. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 5.7.18
    Publication Mise à jour
  2. CVE-2023-34098

    Moyenne · CVSS 5.3EPSS 0,61%Correctif disponible

    Dependency configuration exposed in Shopware

    Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 5.7.18
    Publication Mise à jour
  3. CVE-2022-36102

    Moyenne · CVSS 6.3EPSS 0,8%Correctif disponible

    Acess control list bypassed via crafted specific URLs

    Shopware is an open source e-commerce software. In affected versions if backend admin controllers are called with a certain notation, the ACL could be bypassed. Users could execute actions, which they are normally not able to do. Users are advised to update to the current version (5.7.15). Users can get the update via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

    • Mettez à jour vers 5.7.15
    Publication Mise à jour
  4. CVE-2022-36101

    Moyenne · CVSS 5.4EPSS 0,7%Correctif disponible

    Sensitive data in backend customer module

    Shopware is an open source e-commerce software. In affected versions the request for the customer detail view in the backend administration contained sensitive data like the hashed password and the session ID. These fields are now explicitly unset in version 5.7.15. Users are advised to update and may get the update either via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

    • Mettez à jour vers 5.7.15
    Publication Mise à jour
  5. CVE-2022-31057

    Moyenne · CVSS 6.5EPSS 0,7%Correctif disponible

    Authenticated Stored XSS in Shopware Administration

    Shopware is an open source e-commerce software made in Germany. Versions of Shopware 5 prior to version 5.7.12 are subject to an authenticated Stored XSS in Administration. Users are advised to upgrade. There are no known workarounds for this issue.

    • Mettez à jour vers 5.7.12
    Publication Mise à jour
  6. CVE-2022-24892

    Moyenne · CVSS 6.4EPSS 0,87%Correctif disponible

    Multiple valid tokens for password reset in Shopware

    Shopware is an open source e-commerce software platform. Starting with version 5.0.4 and before version 5.7.9, multiple tokens for password reset can be requested. All tokens can be used to change the password. This makes it possible for an attacker to take over the victim's account if they somehow gain access to the victims email account and find an unused password reset token in the emails. This issue is fixed in version 5.7.9.

    • Mettez à jour vers 5.7.9
    Publication Mise à jour
  7. CVE-2022-24879

    Élevée · CVSS 7.5EPSS 0,6%Correctif disponible

    Malfunction of Cross-Site Request Forgery token validation

    Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

    • Mettez à jour vers 5.7.9
    Publication Mise à jour
  8. CVE-2022-24873

    Moyenne · CVSS 5.4EPSS 0,79%Correctif disponible

    Non-Stored Cross-site Scripting in Shopware storefront

    Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

    • Mettez à jour vers 5.7.9
    Publication Mise à jour
  9. CVE-2022-21651

    Moyenne · CVSS 6.8EPSS 0,77%Correctif disponible

    Open redirect in shopware

    Shopware is an open source e-commerce software platform. An open redirect vulnerability has been discovered. Users may be arbitrary redirected due to incomplete URL handling in the shopware router. This issue has been resolved in version 5.7.7. There is no workaround and users are advised to upgrade as soon as possible.

    • Mettez à jour vers 5.7.7
    Publication Mise à jour
  10. CVE-2021-41188

    Moyenne · CVSS 5.7EPSS 0,76%Correctif disponible

    Authenticated Stored XSS in Administration

    Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

    • Mettez à jour vers 5.7.6
    Publication Mise à jour
  11. GHSA-3pcr-4982-548m

    Non évaluéeCorrectif disponible

    Exposure of .env if project root is configured as web root in shopware/production

    ### Impact The .env and other sensitive files can be leaked if the project root and not `/public` is configured as the web root. ### Patches We recommend to update to the current version 6.3.5.3. You can get the update to 6.3.5.3 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 ### Workarounds You should always use `/public` as the web root. For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index

    • Mettez à jour vers 6.3.5.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →