p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de smarty3

Vulnérabilité publiée pour smarty3 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 7

  1. CVE-2021-29454

    Élevée · CVSS 8.1EPSS 1,8%Correctif disponible

    Sandbox Escape by math function in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.

    • Mettez à jour vers 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publication Mise à jour
  2. CVE-2021-21408

    Élevée · CVSS 8.8EPSS 2,08%Correctif disponible

    Access to restricted PHP code by dynamic static class access in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

    • Mettez à jour vers 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publication Mise à jour
  3. CVE-2018-13982

    Élevée · CVSS 7.5EPSS 3,46%Correctif disponible

    CVE-2018-13982

    Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.

    • Mettez à jour vers 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →