p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in smarty3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für smarty3: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 7

  1. CVE-2021-29454

    Hoch · CVSS 8.1EPSS 1,8%Korrektur verfügbar

    Sandbox Escape by math function in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.

    • Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-21408

    Hoch · CVSS 8.8EPSS 2,08%Korrektur verfügbar

    Access to restricted PHP code by dynamic static class access in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

    • Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2018-13982

    Hoch · CVSS 7.5EPSS 3,46%Korrektur verfügbar

    CVE-2018-13982

    Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.

    • Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2018-16831

    Mittel · CVSS 5.9EPSS 2,66%Korrektur verfügbar

    CVE-2018-16831

    Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.

    • Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →