ALPINE-CVE-2016-2105
ALPINE-CVE-2016-2105
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Integer overflow in the EVP_EncodeUpdate function in crypto/evp/encode.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of binary data.
CVSS 7.5 · High · Fix available
- Published
- Updated
Affected products and versions
openssl Alpine:v3.2
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.3
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.4
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.5
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.6
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0