ALPINE-CVE-2016-2106
ALPINE-CVE-2016-2106
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Integer overflow in the EVP_EncryptUpdate function in crypto/evp/evp_enc.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of data.
CVSS 7.5 · High · Fix available
- Published
- Updated
Affected products and versions
openssl Alpine:v3.2
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.3
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.4
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.5
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.6
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0
openssl Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 1.0.2h-r0
Update to 1.0.2h-r0