p PatchFirst

ALPINE-CVE-2016-9586

ALPINE-CVE-2016-9586

This page contains facts from public vulnerability sources. Check the original advisory before updating.

curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

CVSS 8.1 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl Alpine:v3.2

    Affected ranges
    • ECOSYSTEM: < 7.52.1-r0

    Update to 7.52.1-r0

  • curl Alpine:v3.3

    Affected ranges
    • ECOSYSTEM: < 7.52.1-r0

    Update to 7.52.1-r0

Original sources

Check your server →