p PatchFirst

PatchFirst · Latest vulnerabilities

curl vulnerabilities

Vulnerabilities published for curl in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 22

  1. ALPINE-CVE-2016-8616

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2016-8616

    A flaw was found in curl before version 7.51.0 When re-using a connection, curl was doing case insensitive comparisons of user name and password with the existing connections. This means that if an unused connection with proper credentials exists for a protocol that has connection-scoped credentials, an attacker can cause that connection to be reused if s/he knows the case-insensitive version of the correct password.

    • Update to 7.49.1-r4
    Published Updated
  2. ALPINE-CVE-2016-8615

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-8615

    A flaw was found in curl before version 7.51. If cookie state is written into a cookie jar file that is later read back and used for subsequent requests, a malicious HTTP server can inject new cookies for arbitrary domains into said cookie jar.

    • Update to 7.49.1-r4
    Published Updated
  3. ALPINE-CVE-2016-8624

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-8624

    curl before version 7.51.0 doesn't parse the authority component of the URL correctly when the host name part ends with a '#' character, and could instead be tricked into connecting to a different host. This may have security implications if you for example use an URL parser that follows the RFC to check for allowed domains before using curl to request them.

    • Update to 7.49.1-r4
    Published Updated
  4. ALPINE-CVE-2016-8622

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2016-8622

    The URL percent-encoding decode function in libcurl before 7.51.0 is called `curl_easy_unescape`. Internally, even if this function would be made to allocate a unscape destination buffer larger than 2GB, it would return that new length in a signed 32 bit integer variable, thus the length would get either just truncated or both truncated and turned negative. That could then lead to libcurl writing outside of its heap based buffer.

    • Update to 7.49.1-r4
    Published Updated
  5. ALPINE-CVE-2017-2629

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2017-2629

    curl before 7.53.0 has an incorrect TLS Certificate Status Request extension feature that asks for a fresh proof of the server's certificate's validity in the code that checks for a test success or failure. It ends up always thinking there's valid proof, even when there is none or if the server doesn't support the TLS extension in question. This could lead to users not detecting when a server's certificate goes invalid or otherwise be mislead that the server is in a better shape than it is in reality. This flaw also exists in the command line tool (--cert-status).

    • Update to 7.52.1-r1
    Published Updated
  6. ALPINE-CVE-2017-7468

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-7468

    In curl and libcurl 7.52.0 to and including 7.53.1, libcurl would attempt to resume a TLS session even if the client certificate had changed. That is unacceptable since a server by specification is allowed to skip the client certificate check on resume, and may instead use the old identity which was established by the previous certificate (or no certificate). libcurl supports by default the use of TLS session id/ticket to resume previous TLS sessions to speed up subsequent TLS handshakes. They are used when for any reason an existing TLS connection couldn't be kept alive to make the next handshake faster. This flaw is a regression and identic

    • Update to 7.52.1-r1
    Published Updated
  7. ALPINE-CVE-2016-9594

    High · CVSS 8.1Fix available

    ALPINE-CVE-2016-9594

    curl before version 7.52.1 is vulnerable to an uninitialized random in libcurl's internal function that returns a good 32bit random value. Having a weak or virtually non-existent random value makes the operations that use it vulnerable.

    • Update to 7.52.1-r0
    Published Updated
  8. ALPINE-CVE-2016-9586

    High · CVSS 8.1Fix available

    ALPINE-CVE-2016-9586

    curl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

    • Update to 7.52.1-r0
    Published Updated
  9. ALPINE-CVE-2016-9953

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2016-9953

    The verify_certificate function in lib/vtls/schannel.c in libcurl 7.30.0 through 7.51.0, when built for Windows CE using the schannel TLS backend, allows remote attackers to obtain sensitive information, cause a denial of service (crash), or possibly have unspecified other impact via a wildcard certificate name, which triggers an out-of-bounds read.

    • Update to 7.52.1-r0
    Published Updated
  10. ALPINE-CVE-2016-9952

    High · CVSS 8.1Fix available

    ALPINE-CVE-2016-9952

    The verify_certificate function in lib/vtls/schannel.c in libcurl 7.30.0 through 7.51.0, when built for Windows CE using the schannel TLS backend, makes it easier for remote attackers to conduct man-in-the-middle attacks via a crafted wildcard SAN in a server certificate, as demonstrated by "*.com."

    • Update to 7.52.1-r0
    Published Updated
  11. ALPINE-CVE-2017-7407

    Low · CVSS 2.4Fix available

    ALPINE-CVE-2017-7407

    The ourWriteOut function in tool_writeout.c in curl 7.53.1 might allow physically proximate attackers to obtain sensitive information from process memory in opportunistic circumstances by reading a workstation screen during use of a --write-out argument ending in a '%' character, which leads to a heap-based buffer over-read.

    • Update to 7.52.1-r1
    Published Updated
  12. ALPINE-CVE-2016-7167

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2016-7167

    Multiple integer overflows in the (1) curl_escape, (2) curl_easy_escape, (3) curl_unescape, and (4) curl_easy_unescape functions in libcurl before 7.50.3 allow attackers to have unspecified impact via a string of length 0xffffffff, which triggers a heap-based buffer overflow.

    • Update to 7.49.1-r3
    Published Updated
  13. ALPINE-CVE-2016-7141

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-7141

    curl and libcurl before 7.50.2, when built with NSS and the libnsspem.so library is available at runtime, allow remote attackers to hijack the authentication of a TLS connection by leveraging reuse of a previously loaded client certificate from file for a connection for which no certificate has been set, a different vulnerability than CVE-2016-5420.

    • Update to 7.49.1-r2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →