ALPINE-CVE-2017-14919
ALPINE-CVE-2017-14919
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service (uncaught exception and crash) by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0
nodejs Alpine:v3.9
- Affected ranges
- ECOSYSTEM: < 6.11.5-r0
Update to 6.11.5-r0