p PatchFirst

PatchFirst · Latest vulnerabilities

nodejs vulnerabilities

Vulnerabilities published for nodejs in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. ALPINE-CVE-2017-15897

    Low · CVSS 3.1Fix available

    ALPINE-CVE-2017-15897

    Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100, "This is not correctly encoded", "hex");' The buffer implementation was updated such that the buffer will be initialized to all zeros in these cases.

    • Update to 8.9.3-r0
    Published Updated
  2. ALPINE-CVE-2017-15896

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2017-15896

    Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.

    • Update to 8.9.3-r0
    Published Updated
  3. ALPINE-CVE-2017-14919

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-14919

    Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service (uncaught exception and crash) by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter.

    • Update to 6.11.5-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →