ALPINE-CVE-2017-15896
ALPINE-CVE-2017-15896
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.
CVSS 9.1 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0
nodejs Alpine:v3.9
- Affected ranges
- ECOSYSTEM: < 8.9.3-r0
Update to 8.9.3-r0